前几天发布博客的时候,遇到这个警告和错误:

Google 得出的结果是 Jekyll 和 Pygments 版本兼容问题:Jekyll on Windows: Pygments not working
按照 @zzheng 的回答:

gem uninstall pygments.rb --version ">0.5.0"
gem install pygments.rb --version "=0.5.0"

降低 Pygments 的版本不起作用,因为 Jekyll 2.5.3 要求 Pygments 的最低版本为 0.6.1.
试着更新 gem 也无果:

甚至在 _config.yml 禁用 highlighter 也无济于事。
最后,试着把 markdown 文件里代码块的写法


1
2

</pre>
换成 codeblock,居然就不报错了 …

WTF!